GovernorHub not loading for some users
Incident Report for GovernorHub
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 21, 2019 - 16:20 GMT
Investigating
We are currently investigating an issue that's preventing GovernorHub from loading for some users. Please keep checking back here for further updates.
Posted 7 months ago. Jan 21, 2019 - 14:32 GMT
This incident affected: GovernorHub Website and GovernorHub Admin website.