Issues with GovernorHub
Incident Report for GovernorHub
Resolved
Everything seems to be returning to normal 🤞🏻 Thanks for your patience while we got it sorted!
Posted about 1 month ago. Jul 09, 2019 - 14:52 BST
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 09, 2019 - 14:51 BST
Investigating
We’re having issues with GovernorHub this afternoon. We're working hard to find a solution and we’ll keep everyone updated. Thanks for bearing with us!
Posted about 1 month ago. Jul 09, 2019 - 14:23 BST
This incident affected: GovernorHub Website, GovernorHub iOS App, GovernorHub Android App, GovernorHub API, and GovernorHub Admin website.