Sporadic failures
Incident Report for GovernorHub
Resolved
All seems to be quiet on the western front
Posted 9 days ago. Aug 13, 2019 - 12:53 BST
Monitoring
We've given the servers a stern talking to and for now they seem to be behaving themselves. We'll keep monitoring for a little while, but hopefully things should now be back to normal.
Posted 9 days ago. Aug 13, 2019 - 11:46 BST
Investigating
We're investigating some sporadic network failures this morning that are causing some issues - parts of the site may fail to load. Please bear with us, and sorry this is happening!
Posted 9 days ago. Aug 13, 2019 - 11:35 BST
This incident affected: GovernorHub Website, GovernorHub iOS App, GovernorHub Android App, GovernorHub API, and GovernorHub Admin website.