Performance slow down
Incident Report for GovernorHub
Resolved
OK - we think we've fixed this problem but are monitoring the situation.
Posted over 2 years ago. May 24, 2017 - 17:07 BST
Investigating
We're seeing a few slow responses at the moment on GovernorHub which can meaning page loading can take a long time. We're looking at it.
Posted over 2 years ago. May 24, 2017 - 16:17 BST