Problems with Safari 8/9
Incident Report for GovernorHub
Resolved
We've found and fixed the problem with Safari. Everything should now be A-OK
Posted almost 3 years ago. Nov 10, 2016 - 11:59 GMT
Investigating
We're currently aware of problems accessing GovernorHub with the Safari browser, specifically version 8/9. We're working to fix this, but for now please use a different browser.
Posted almost 3 years ago. Nov 10, 2016 - 10:19 GMT