GovernorHub not loading
Incident Report for GovernorHub
Resolved
We tracked this down to an issue with our internal routing resolving old (and now non-existent) IP addresses. This was causing requests to hang. Restarting the affected component sorted matters out
Posted about 2 years ago. Sep 25, 2017 - 10:38 BST
Investigating
We're looking into reports of GovernorHub not loading
Posted about 2 years ago. Sep 25, 2017 - 10:05 BST