Network problems
Incident Report for GovernorHub
Resolved
Beavering complete - hopefully things are back to being tip-top again, but we'll keep our eyes on it.
Posted almost 3 years ago. Jan 12, 2017 - 17:03 GMT
Investigating
We're seeing intermittent problems within our network which may cause some rather annoying sporadic failures. As I type we're beavering away trying to get it fixed up
Posted almost 3 years ago. Jan 12, 2017 - 16:30 GMT