GovernorHub not loading for some users
Incident Report for GovernorHub
Resolved
This incident has been resolved.
Posted over 1 year ago. May 02, 2018 - 15:00 BST
Identified
The cause of the problem has been identified and we are now working to fix it.
Posted over 1 year ago. May 02, 2018 - 14:27 BST
Investigating
We are currently investigating an issue that's preventing GovernorHub from loading for Internet Explorer users. While we get this resolved, if you have a different browser installed please try using it to access GovernorHub. Please keep checking back here for further updates.
Posted over 1 year ago. May 02, 2018 - 13:59 BST
This incident affected: GovernorHub Website.