GovernorHub outage
Incident Report for GovernorHub
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 15:14 BST
Monitoring
Things seem to be getting back to normal - we are still monitoring it closely.
Posted Oct 14, 2021 - 13:28 BST
Update
We are continuing to investigate this issue.
Posted Oct 14, 2021 - 12:13 BST
Investigating
GovernorHub appears to be down for the majority of users. We are investigating this ongoing issue and will post updates as soon as we know more. So sorry for any inconvenience this causes.
Posted Oct 14, 2021 - 12:12 BST
This incident affected: GovernorHub Website, GovernorHub iOS App, GovernorHub Android App, GovernorHub API, and GovernorHub Admin website.