Some reports not working
Incident Report for GovernorHub
Resolved
We tracked down and fixed the bug and everything should now be back up and running as normal.
Posted about 2 years ago. Oct 12, 2017 - 11:45 BST
Investigating
We are aware that some reports can't be downloaded. We are looking into it.
Posted about 2 years ago. Oct 12, 2017 - 11:18 BST