GovernorHub outage
Incident Report for GovernorHub
Resolved
Things seem to be back up and running - we are still monitoring it closely.
Posted Feb 24, 2021 - 16:03 GMT
Monitoring
We think things are returning to normal and we are monitoring it closely.
Posted Feb 24, 2021 - 15:23 GMT
Investigating
GovernorHub appears to be down for the majority of users. We are investigating this ongoing issue and will post updates as soon as we know more. So sorry for any inconvenience this causes.
Posted Feb 24, 2021 - 15:03 GMT
This incident affected: GovernorHub Website, GovernorHub iOS App, GovernorHub Android App, GovernorHub API, and GovernorHub Admin website.